jump to navigation

Problema con webcam en Ubuntu 8.10 9 enero 2009

Posted by bushwaca in Aplicaciones, Linux, Ubuntu.
Tags: , , ,
trackback
cheese

Cheese

Si ustedes tienen una instalacion por defecto de Ubuntu podran ver que su camara funciona en su aMSN, Skype y en muchas otras aplicaciones, pero si quieren testearla con por ejemplo “Cheese”, la webcam prende la luz pero no muestra imagen. Este problema que ocurre con “Cheese” puede ocurrir con muchos otros, pero en realidad no es que no reconoce nuestra camara nuestro ubuntu, sino que es un problema de paqueteria o librerias. Para mi, aplicaciones como esta, son las mas comunes para testear una webcam pero parece ser que tienen problemas. En resumen Ubuntu ve nuestra webcam, el tema son los paquetes y librerias aparentemente.

Se me hace dificil escribir esto ya que es a pedido de un lector, pero me gusto la propuesta y puede ser util. No soy un usuario de webcams, es mas no me gustan, pero me parecio divertido y raro de que lo pase por alto al testear Ubuntu. No es una solucion completa sobre webcams, pero puede servir para los que quieran investigar mas sobre este tema.

En definitiva intentare explicarles como solucionar este problema con el programita “Cheese” para que podamos ver imagen y  no que solamente encienda la luz.

Comencemos:

1 – Abrimos una consola he instalamos cheese:
sudo apt-get install cheese

2 – Ejecutamos cheese desde consola:
cheese

Veremos que enciende la luz de la camara pero se ve todo negro. Ademas, veremos un mensaje de error en la consola con la que abrimos el programa y si nos fijamos en un momento nombra a la libreria “v4l” (video for linux). Puede que les diga “libv4l2” como era mi caso. Esta creo que es la ultima version de esta libreria, pero nosotros vamos a instalar otra version para que nos funcione bien. Luego si se actualiza la “lbv4l2” de nuestro ubuntu, nos avisara llegado el caso.

3 – Editamos la lista de repositorios:
sudo gedit /etc/apt/sources.list

4 – Pegamos al final del fichero este repo:
##Libreria para camara web
deb http://ppa.launchpad.net/lool/ubuntu intrepid main
deb-src http://ppa.launchpad.net/lool/ubuntu intrepid main

5 – Actualizamos la lista de paquetes:
sudo apt-get update

6 – Instalamos la libreria libv4l-0 :
sudo apt-get install libv4l-0

7 – Abrimos Cheese desde consola:
cheese

Y nos mostrara imagen y no nos mostrara ningun mensaje de error en la consola.

Nota: a mi particularmente me dio un problemita de paquetes (supongo que le estarian cambiando algo al repo justo en ese momento o algo) pero se instalo igual esa libreria por lo que actualice nuevamente la lista de paquetes con “sudo apt-get update” luego volvi a editar el sources.list con “sudo gedit /etc/apt/sources.list”, borre las lineas que habia agregado y volvi a actualizar la lista de paquetes para que corrija estos problemitas con “sudo apt-get update”. De esta manera volvia a tener todo como antes solo que teniendo esta nueva libreria.

Bueno espero que les sea util y hasta la proxima.

Comentarios»

1. Electronic gadget guide and reviews » Problema con webcam en Ubuntu 8.10 - 9 enero 2009

[…] Original post by Mi Block de Notix […]

2. bushwaca - 9 enero 2009

Bueno, me adelanto un poco ya que escribi esto por un comentario de Erik al cual respondere aqui:

1- Si, este kernel actual que usa ubuntu tiene soporte para muchas webcams (o por lo menos eso tengo entendido)
2 – Solo como dato te puede interesar ver la web de Michel Xhaard que es un fenomeno de la naturaleza. Este frances escribio drivers para mas de 250 webcams usb para linux:
http://mxhaard.free.fr/spca5xx.html
3 – Aun no se bien cual es tu problema con la webcam. Lo unico que te digo es que en teoria deberia ser este tu problema ya que por lo que vi deberia levantartela sola con la laptop que usas.
4 -Si tu consulta es para hacer funcionar una camara usb es otro cantar, es un mundo diferente. Tengo una camara asi y la hice funcionar en varias versiones de ubuntu pero la tengo por ahi tirada… supongo que en algun momento me dispondre a hacer un post sobre ella.
5 -Si directamente cuando pones el Cheese ni enciende la luz proba poniendo:
dmesg | grep video
Que deberia darte una salida similar a esto:
[ 1.474082] pci 0000:00:12.0: Boot video device
[ 16.245377] Linux video capture interface: v2.00
[ 16.493295] uvcvideo: Found UVC 1.00 device CNF7040 (04f2:b055)
[ 16.589358] usbcore: registered new interface driver uvcvideo

Si te dice “Failed” es un problema del “uvcvideo” que es nuevo driver para webcams de ubuntu que agregaron en este kernel (el que soporta como 100 webcams o mas)
De ser asi busca por ese lado solucionar tu problema y recuerda que este driver es muy nuevo por lo cual esta verde.

3. Erik - 12 enero 2009

Acabo de leer y la verdad eres un tipazo mas que por la solución es por tu amabilidad te agradezco mucho tu respuesta hoy en la noche la probare y muchas gracias de verdad me e quedado con una gran satisfacción que eres una gran persona.

4. bushwaca - 12 enero 2009

Bueno, muchas gracias, pero la verdad que es un placer para mi. Cualquier cosita me consultas, y si puedo ayudarte lo intentare.
Puede que sea algo mas dificil, siempre es mas facil teniendo la pc delante, pero podria guiarte un poco a que te sea mas facil solucionar tu problema.

PD: Intenta probar si funciona tu webcam con el aMsn, a mi me funcionaba sin hacer nada, pero para hacer funcionar Cheese tuve que hacer lo que puse aqui.

Suerte.

5. Erik - 20 enero 2009

Despues de una semana sin internet (ISP muy mal), hice lo que me indicaste pero no parti de la base de que debia verificar si el SO me detectaba la camara…. efectivo no reconoce la camara entonces ahora tendre que buscar algún driver que le sirva a esta camarita itegrada verificare primero en la pagina que indicas, muchas gracias por la ayuda.

6. bushwaca - 22 enero 2009

Uff que pena entonces. Espero que lo soluciones pronto, suerte con eso y es un placer.

7. schatten - 23 enero 2009

Salu2 bushwaca….

Oye amigo… una ayudita… tengo una cam messenger 3.10… depúes de estar horas tratando de compilar el gspca-source la logre levantar con el gstreamer… es decir gstreamer-properties en la ficha video, le doy test y puedo ver la cam (aunque no prende el led) la puedo ver pero veo la imagen invertida, osea con un giro de 180°….

Trate de usarla con aMsn pero no funcó..

aca te dejo el lsusb si me puedes ayudar!!!

Bus 001 Device 003: ID 093a:2624 Pixart Imaging, Inc.

tienes alguna idea de como hacerla ver normal, lo de hacerla funcar con aMsn, voy a probar una solucion que encontre por ahí…

La verdad esto es para mis hermanas que me tienen loco y que prefieren windows por la cam, yo tengo mi laptop y la mia funca bn…😛

8. bushwaca - 23 enero 2009

a) No podria decirte con exactitud, ya que cada camara es un mundo diferente, mas si de una usb se trata. Si tuviese la camara por ahi seria diferente la cosa.

b) Seguro hay algun problemita con eso que complitaste. Intenta ver en las opciones de ahi o puede que directamente debas configurar algo antes de compilar porque estas viendo imagen.

c) Muchos modelos de Pixart son compatibles con linux, no se especificamente esa, pero podria funcionar con el driver “spca5xx” o con el “gspcav1” tambien.

d) Para testear la camara usa algun programa de mensajeria he incluso el “cheese” pero primero hace esto de aqui ya que sino puede que no te funcione el cheese. No te recomiendo que uses camorama para hacerlo.

e) La marca es Genius, una Logitech? Porque Pixart es el fabricante creo pero solo se llama “cam messenger 3.10” la webcam?

d) Por lo general es mejor manejarse montando y desmontando modulos sin compilacion, pero hay que ver que tan dura es esa cosa.

f) Cuando testees la webcam inicia la aplicacion siempre desde consola para ver que es lo que tira. Como por ejemplo “cheese” de otro modo no te enteras cual es el problema. Tambien para “parchar” tu problema puedes mirar en las opciones de los programas, muchos permiten girar la imagen.

g) Nunca lo olvides… en estos casos lo mejor es abusar de nuestro amigo Google jajaja.

Bueno, no es de mucha ayuda pero algo es algo xD

9. schatten - 28 enero 2009

Hola viejo amigo!!

Despues de darme cuenta… mucha bola… nunca pude recompilar el modulo gspac-source.. porque el ubuntu 8.10 ya los tenia arriba!!!…

mucha abeja!!, en fin

Por ahora voy a probar el cheese… haber como funca, si la puedo voltear o algo….

estuve intentado meterle un vflip en el modulo gspca_main y gspca_7311, pero no funco!

voy a ver si se puede en otros modulos…

Salu2

10. schatten - 28 enero 2009

Se me olvido decir que la camara es una Genius

Salu2

bushwaca - 31 enero 2009

Uff me imagino como estaras con eso. Bueno, por lo que vi no esta soportada exactamente esa webcam que tienes, pero si lo estan muchas camaras genius. La gran mayoria funciona con el spca5xx , podrias intentarlo con ese. Si me hago algo de tiempo intento instalar mi webcam usb si es que la encuentro y te muestro como hice.

11. Webcam Genius en Ubuntu « Mi Block de Notix - 2 febrero 2009

[…] es probar con el aMSN ya que pueden tener algun problema con esos programas como explique en un post anterior y si quieren hacerlo con Cheese miren este post por las […]

12. reebot - 4 febrero 2009

fantástico, después de muchas vueltas ha funcionado ,haciendo todo lo que dices, gracias muchas gracias

13. bushwaca - 4 febrero 2009

Me alegro entonces, gracias por comentar.

14. un - 25 febrero 2009

Hola crak!

He seguido tus passos pero no me deja instalar el paquete libv4l-0 ya que me dice que se encuentra en una version más actualzada… Como lo puedo hacer? gràcias!

bushwaca - 25 febrero 2009

1) Bien… si agregaste esos repositorios como puse ahi deberias poder descargarla he instalarlo, pero si te da problemas o no puedes hacerlo intenta desde aqui dependiendo tu arquitectura

http://packages.debian.org/unstable/libs/libv4l-0

Luego de descargarla puedes hacer alguna de estas dos cosas:
a) Una vez que la descargas le das doble click, te sale un cartel de que la libreria es antigua, pones “cancelar” y luego instalar el paquete.
b) Vas a la carpeta donde descargaste la libreria y pones:
sudo dpkg -i "NOMBREDELALIBRERIA"

2) Usas “sudo” para intentar instalar el paquete? Puede que tenga un “bache mental” pero en teoria el usuario root es el “amo y señor” y puede hacer lo que que de la gana, es decir que usando “sudo” deberias poder hacer lo que quieres, incluso instalar una libreria por mas de que esta sea antigua. Fijate si te da la opcion de instalar la libreria igualmente por mas de que sea antigua mientras lo vas instalando.

15. un - 28 febrero 2009

Hola!

Muchas gracias por tu brespuesta, mea culpa; agregué los repostorios, pero ya no me acordava que dos dias antes havia actualizado a junty… y los repostorios son para hardy…

bajando este paquete y clicand sobre, me dice que ya está instalado, y me pide si lo quiero reinstalar, acepto, lo reinstala, abro cheese por consola y sigue igual… :S

“libv4l2: error dequeuing buf: Input/output error”

Muchas gracias de todas formas.🙂

bushwaca - 28 febrero 2009

ahhhh ahora si.
Pues, bueno…. como supuesto ya que aun no tengo instalada esa version dejame decirte que la solucion puede ser diferente ya que tiene otro kernel y otra paqueteria.

La verdad, como opinion personal, este tipo de programas (cheese, camorama) en las ultimas versiones de Utuntu por lo general no funcionan por defecto como lo hacian antes y creo particularmente no deben usarse para testear las webcams por el momento.
Personalmente te recomiendo que uses algun programa de mensajeria instantanea para hacerlo como el aMsn que no hay que hacer practicamente nada para probarla, solamente seguir el asistente que trae.

Suponiendo que usas cheese solo para ver si funciona tu camara, te diria que si no funciona siguiendo el asistente del aMsn intentes instalar la webcama la antigua instalando algun paquete. Eso dependera de tu camara, pero para guiarte mas o menos como es la cosa podria mirar este link para entender como se hace (esto es una forma y no es la unica).

Bueno, mucha suerte y espero que soluciones tu problema.

16. suprlink - 29 marzo 2009

ayuda este es el problema de mi webcam algien me puede decir donde soluciono esto soy nuevo con este sistema

[ 1.197030] pci 0000:00:05.0: Boot video device
[ 14.612132] Linux video capture interface: v2.00
[ 14.726988] uvcvideo: Found UVC 1.00 device USB2.0 PC CAMERA (18ec:3288)
[ 14.731371] uvcvideo: Failed to query (135) UVC control 1 (unit 0) : 0 (exp. 26).
[ 14.734560] usbcore: registered new interface driver uvcvideo
[ 29.823340] uvcvideo: Failed to query (130) UVC control 1 (unit 0) : 0 (exp. 26).
[ 2109.734080] uvcvideo: Failed to query (130) UVC control 1 (unit 0) : 0 (exp. 26).
[ 2109.791080] uvcvideo: Failed to query (130) UVC control 1 (unit 0) : 0 (exp. 26).
[ 2109.812082] uvcvideo: Failed to query (130) UVC control 1 (unit 0) : 0 (exp. 26).
[ 2110.021083] uvcvideo: Failed to query (130) UVC control 1 (unit 0) : 0 (exp. 26).
[ 2119.431085] uvcvideo: Failed to query (130) UVC control 1 (unit 0) : 0 (exp. 26).
[ 2120.636087] uvcvideo: Failed to query (130) UVC control 1 (unit 0) : 0 (exp. 26).
[ 2126.994081] uvcvideo: Failed to query (130) UVC control 1 (unit 0) : 0 (exp. 26).

bushwaca - 29 marzo 2009

1 – Bien, por lo que parece tienes un problemita con el uvcvideo, que si mal no recuerdo es el driver “nuevo” para webcams que se puso en el kernel.
2 – No tengo idea de que camara se trata, que kernel tienes (aunque puedo suponer ma o menos cual es por el diver uvcvideo), que distro usas, ni que comando tiraste que te dio esa salida (aunque puedo suponerlo tambien) y que hardware tienes (si es una laptop y cual es por ejemplo).
3 – Mi recoemendacion es que hagas un “lspci” en consola, mires que webcam tienes y “goglees” con eso.

Suerte.

17. mauricio - 12 abril 2009

hola esperoq eu este bien ,muy buena la explicaicon gracias y felicitaciones, entrando al tema hice lo que dispones arriba y me funciono con chesse, pero al utlizar amsn no fundiona que podria ser eso? gracias espero pronta respeusta

18. bushwaca - 13 abril 2009

a) Bueno, esto siempre es dificil, pero si puedes apuntame que camara tienes, que distro usas, que pc tienes (por si es una laptop) y que version de amsn tienes. Si te funciona cheese quiere decir que la camara anda, el tema es configurarla para que funcione con amsn.

b) aMsn si no estoy mal usa v4l2 para la webcam. Verifiquemos que este… pone en consola:
aptitude search v4l2

Y debe darte una salida como esta:
i libpt-1.10.10-plugins-v4l2 (i = instalado)
p libpt-1.11.2-plugins-v4l2
v libpt-plugins-v4l2

c) Seguiste el asistente del amsn para configurar la camara?
1 – Ejecuta en un terminal:
amsn
2 – No te loguees con tu cuenta.
3 – En la ventana del aMsn ve a “Cuentas – Preferencias – Otras” y hace click en “Configurar camara web”
4 – Aparecera la presentacion del asistente. Le das a siguiente.
5 – Aca esta el tema (supuestamente aqui deberias verte)
Aqui vas a ver dos menus desplegables. El primero es para seleccionar el dispositivo y el segundo para el canal.
En el caso de que tambien tengas por ejemplo una capturadora de video puede que tengas dos opciones en dispositivos, con lo cual elije tu camara. Siguiente cuando la encuentres o te veas.
6 – Luego te da detalles sofre el brillo y demas si es que quieres tocarlo.
7 – Despues para el sonido. De paso le das a probar.
8 – Microfono. en el caso de tener uno lo chequeas.
9 – Te da un resumen y si quieres que tu camara este disponible para que la vean los demas. Listo.
10 – Si no funciono y no viste nada mira la terminal donde ejecutaste el amsn y dime si no aparece algun error.

Suerte.

19. victor - 20 septiembre 2009

al ejecutar cheese en la terminal me apraece una lista de errores interminable

libv4lconvert: Error decompressing JPEG: unknown huffman code: 0000ffd9
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 1 more bits
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 1 more bits
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 1 more bits
libv4lconvert: Error decompressing JPEG: fill_nbits erro

de echo se repite el de arriba mi camara en msi y si prende el foquito verde pero no se ve nada bueno solo una patalla verde con colores arriba

20. victor - 20 septiembre 2009

ya le instale las librerias libv4l-dev y libv4l-ruby1.8 y ahora me sale esto

libv4l2: error turning on stream: No se puede asignar memoria
libv4l2: error dequeuing buf: Argumento inválido

y ahora se ve los clasicos cuadros de video antiguo los cuadrotes de colores con una cuadro pequeños en la esquita de interferencia blanco y negro pero ya no pendrio el foquito verde

bushwaca - 21 septiembre 2009

1) No se que camara tienes. Un “lsusb” puede que ayude.
2) Estas usando ubuntu 8.10?
3) Intentaste poner tu camara con aMsn en vez de con Cheese?
4) En ubuntu 9.04 no me da ningun tipo de error de esos.

Saludos y suerte con eso.

21. carlos - 7 noviembre 2009

tengo ubuntu 9.10 y me da el mismo error que a victor en el cheese mi camara es una microsoft corp. lifecam vx-3000. le puse otra camara y funciono pero con esta no se k pasa. en mandriva me funcionaba bien.te juro que cuando la ponga a funcionar sentire el
extasis intelectual.

bushwaca - 7 noviembre 2009

1) Estas usando Ubuntu 8.10?
2) Intentaste poner tu camara con aMsn en vez de con Cheese?
3) En ubuntu 9.10 no me da ningun tipo de error de esos.
4) Tal vez esto te puede servir:
https://miblockdenotix.wordpress.com/2009/02/02/webcam-genius-en-ubuntu/

Saludos y suerte.


Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

A %d blogueros les gusta esto: